Server issues
Incident Report for Bandsintown
Resolved
This incident is now resolved.
Posted 4 months ago. Jun 20, 2019 - 18:05 EDT
Investigating
Hi, we are currently observing server issues affecting the loading of data in some cases. If you run into this issue, please try reloading the page. We are working on it and will update you as soon as we have more information. Apologies for the inconvenience and thank you for your patience!
Posted 4 months ago. Jun 20, 2019 - 17:30 EDT
This incident affected: Bandsintown Manager.