Email sign up currently unavailable
Incident Report for Bandsintown
Resolved
This incident is now resolved! Sorry for the inconvenience.
Posted 6 months ago. Apr 18, 2019 - 13:10 EDT
Identified
Hi, our email sign up capability is currently unresponsive. Please consider signing up through Facebook Connect if you're in a hurry, or give us a bit of time and we'll get this fixed shortly. Thanks for your patience!
Posted 6 months ago. Apr 18, 2019 - 12:30 EDT
This incident affected: Bandsintown Manager.