Server Issue
Incident Report for Bandsintown
Resolved
We have resolved this issue and all systems are be back up and running now, thanks for your patience.
Posted 3 months ago. Jul 15, 2019 - 12:54 EDT
Investigating
We are currently experiencing an issue with Bandsintown Manager and we are investigating.
Posted 3 months ago. Jul 15, 2019 - 11:53 EDT
This incident affected: Bandsintown Manager.