Intermittent delays
Incident Report for Bandsintown for Artists
Resolved
This incident has been resolved.
Posted Feb 20, 2020 - 19:31 EST
Investigating
We are currently experiencing intermittent delays on Bandsintown for Artists. We are looking into this.
Posted Feb 20, 2020 - 16:17 EST
This incident affected: Manager Application.