Page loading errors
Incident Report for Bandsintown for Artists
Resolved
This incident has been resolved. Thank you for your patience and have a great weekend!
Posted Mar 13, 2020 - 17:10 EDT
Identified
We are observing errors which may affect the loading of pages on Bandsintown for Artists. We are working on a fix and will update this incident as soon as possible.
Posted Mar 13, 2020 - 15:30 EDT
This incident affected: Manager Application.