Event editing issue

Incident Report for Bandsintown

Resolved

This incident has been resolved. We apologize for any inconvenience.
Posted Mar 25, 2025 - 09:49 EDT

Investigating

An outage is currently affecting event editing on Bandsintown for Venues and Bandsintown for artists. We will keep you posted. We are sorry for the inconvenience
Posted Mar 25, 2025 - 09:14 EDT
This incident affected: Bandsintown for Artists and Bandsintown Pro for Venues.