Post to trackers, messages to fans and releases are not working
Incident Report for Bandsintown
Resolved
This incident has been resolved.
Posted Nov 23, 2023 - 12:18 EST
Investigating
We are currently investigating the issue
Posted Nov 23, 2023 - 11:38 EST
This incident affected: Bandsintown for Artists.