Post to tracker outage
Incident Report for Bandsintown
Resolved
This incident has been resolved.
Posted Jul 03, 2023 - 10:04 EDT
Investigating
An outage is currently affecting post to trackers. Email builder is working.
We are investigating.
Posted Jul 03, 2023 - 09:41 EDT
This incident affected: Bandsintown for Artists.