Events + email Builder not showing up on manager web

Incident Report for Bandsintown

Resolved

This incident has been resolved
Posted Oct 20, 2022 - 14:53 EDT

Investigating

Events do not display or be created and new email campaigns can not be started on manager-web. We are investigating
Posted Oct 20, 2022 - 14:45 EDT
This incident affected: Bandsintown for Artists.